GrowCut 3.0 + GIMP 2.8

2015-01-06 :  PCクリニック
本文の前に、
-・・・ -・-
現時点での blogramのランクインカテゴリは、
6、1、0、1、1、 0、0、0、0、0(41)で、換算ポイント 74pt 。
三日前と変わらずだが、・・・
相変わらず「C言語」「Firefox」「化学業界」「グルコサミン」のbg値が、
毎日の如く変動している。
・-・ - -・

さて、本文。

前(2015-01-03)の記事:
GrowCut 3.0 + Photshop 6.0
では、


GrowCut 3.0.1」を
「Windows 7 x64」マシンに於いて、
Adobe Photoshop 6.0
で使うことにした。

更には、
「英語版Pixia」経由で「PictBear」ででも使えた。


ですが、フリーソフトで使うなら、・・・
やはり、「GIMP」でしょうか?

その前に、もう1つあった。
「IrfanView」ですね。

これで、やってみたが、・・・・・
「GrowCut 3.0」が、ダメだと云って立ち上がらない。

「IrfanView Support Forum」の「GrowCut Mask」の
How Can I Erase the Background of an Image?
の中に、
  01.02.2012, 12:36 PM ( #3 )
  We had this topic already in the forum!
  see:
  "How to change the background of this photograph?"
がある。

見に行くと、半分より下にある:
  08.06.2009, 03:52 PM ( #7 )
  Originally Posted by MItaly

  I think that IrfanPaint is not the right tool,
  you should use something more advanced like the GIMP.

等となっている。

IrfanPaint」って?
  IrfanPaint is an open-source plug-in
   that adds painting features to IrfanView;
  it is developed by Matteo Italia ( ・・・ ) and,
   as IrfanView, it is freeware.

詰まるところ、
  「IrfanView」を使うのは間違い
  何かもっとマシなもの(例えば「GIMP」とか)を使うべきダ。
と云うことでしょうか。


それで、「GIMP」なのだが、
実は、別件で「gimp-2.8.10-setup.exe」86.2MB を、
2014-04-10 にダウンロードしていた。

これを、使ってみる???


GrowCut 3.0 User's Guide」の
System Requirements」にある、
  ・The GIMP ( Notes )
の補足には、

  In order to use .8bf plug-ins
   you need to download and install PSPI module:
  http://www.iki.fi/tml/gimp/pspi.html
  Then, don't forget to configure PSPI's plug-in folder to
  the one where you put GrowCut.8bf file.

なので、
  Windows
  The Windows package includes just pspi.exe.
  Put it in your GIMP plug-ins folder,
  typically ~/Program Files/GIMP/lib/gimp/2.0/plug-ins.


「GIMP-2.8.10」をインストールした後に、

「gimp-pspi-1.0.7.win32.zip」19.5KB
を展開してみると、「pspi.exe」49.0KB 1つ。
これを、上記の、
  C:/Program Files/GIMP 2/lib/gimp/2.0/plug-ins/
に入れた。

それからの作業は、
「Windows GIMP Photoshop プラグイン」とかで検索すると、色々見つかる。


GIMPの「フィルタ」メニューに
「Photoshop Plug-In Settings...」サブメニューができているので、
プラグインの場所を指定する。
すると、
「フィルタ」メニューに「iPhotoSoft」サブメニューができて、
その中は、「GrowCut 3.0...」1つ。

で、確かに「GrowCut 3.0」が使えた。

・・・・・・・・・・・・・・・

ところが、何かをしてしまったら
「GIMP」の立ち上げ時にほにゃららエラーメッセージがでて、
「GIMP」自体が使えなくなった。

これは大変ダ。

検索したら、救世主(Google Groups)が居た。
Help please! I cannot open The Gimp....

  Make sure that the plugin.dll from your Photoshop installation can be
  found (e.g. is in the PATH environment variable), or, if you don't
  have Photoshop, do the following:

  Open the file gimprc in the .gimp-1.2 directory (this should be in
  your profile directory) in a text editor. Change the pspi-path
  setting


「plugin.dll」が無いので、・・・ と云うエラーだったら、
「Photoshop」から抜き出して、「GIMP」に入れてやる。
「Photoshop」を持っていなかったら、「gimprc」と云うファイルを修正する!
で、そのファイルは何処に?

  C:/Users/<ユーザー>/.gimp-2.8/

にある!

コメントが多いが、
大事なのは1行:
  (pspi-path "~~~")
ダケ。


これで、「GIMP 2.8」でも、「GrowCut 3.0」を安心して使える。


本日はここまで。


見ていただいた序でとは厚かましい限りですが、
お帰りに投票して頂けるとなお嬉しいです。 ⇒ blogram投票ボタン


141211
関連記事
スポンサーサイト

コメントの投稿

管理者にだけ表示を許可する

おきてがみ/blogram
blogram投票ボタン



おきてがみ

最新記事
カレンダー
09 | 2017/10 | 11
1 2 3 4 5 6 7
8 9 10 11 12 13 14
15 16 17 18 19 20 21
22 23 24 25 26 27 28
29 30 31 - - - -
月別アーカイブ
カテゴリ
最新コメント
検索フォーム
リンク
プロフィール

<紙>

Author:<紙>
ようこそ。
「パソコンヲタクの雑記帳」
もろもろなことを綴っています。
パソコン ヲタクってねくら?
画像は kami でなく kani です。

カウンター(fc2、i2i) /Google Analytics


i2i(from 2010-08-24)
Total =
Today  =  
Yesterday=
アンチエイジング

Google Analytics
ブックマーク